NAME | SYNOPSIS | DESCRIPTION | FILES | EXIT STATUS | SEE ALSO | HISTORY | COLOPHON
NEWALIASES(8) BSD System Manager's Manual NEWALIASES(8)
newaliases — rebuild mail aliases
newaliases [-f file]
The newaliases utility makes changes to the mail aliases file visible to smtpd(8). It should be run every time the aliases(5) file is changed. The location of the alias file is defined in smtpd.conf(5), and defaults to /etc/mail/aliases. The options are as follows: -f file Use file as the configuration file, instead of the default /etc/mail/smtpd.conf. If using database (db) files, newaliases is equivalent to running makemap(8) as follows: # makemap -t aliases /etc/mail/aliases If using plain text files, newaliases is equivalent to running smtpctl(8) as follows: # smtpctl update table aliases
/etc/mail/aliases List of local user mail aliases. /etc/mail/virtual List of virtual host aliases.
The newaliases utility exits 0 on success, and >0 if an error occurs.
smtpd.conf(5), makemap(8), smtpctl(8), smtpd(8)
The newaliases command first appeared in OpenBSD 4.6 as a replacement for the equivalent command shipped with sendmail.
This page is part of the OpenSMTPD (a FREE implementation of the server-side SMTP protocol) project. Information about the project can be found at https://www.opensmtpd.org/. If you have a bug report for this manual page, see ⟨https://github.com/OpenSMTPD/OpenSMTPD/issues⟩. This page was obtained from the project's upstream Git repository ⟨https://github.com/OpenSMTPD/OpenSMTPD.git⟩ on 2022-12-17. (At that time, the date of the most recent commit that was found in the repository was 2022-09-30.) If you discover any rendering problems in this HTML version of the page, or you believe there is a better or more up-to-date source for the page, or you have corrections or improvements to the information in this COLOPHON (which is not part of the original manual page), send a mail to email@example.com BSD July 20, 2018 BSD